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Introduction

Brown dwarfs are objects occupying the gap between the least massive stars and the most massive
planets. They are intrinsically faint objects so their detection is not straightforward and, in fact,
was almost impossible until the advent of global surveys at deep optical and near-infrared bands like
SDSS, 2MASS or DENIS among others. We propose here to mine the 2MASS point source catalogue
(2MASS-PSC) and SDSS-DR9 databases to identify T-type brown dwarfs through an appropriate
combination of colours in the optical and the infrared, an approach that perfectly fits into the Virtual
Observatory.
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Goal of this tutorial

In this use case, we explore different ways to do the same tasks with different VO tools. These tasks
include:
• obtaining data from the SDSS and 2MASS catalogues in a given sky region,
• crossmatching the results of these searches,
• filtering the resulting table for brown dwarfs, and
• verifying our sample of brown dwarfs.
Software packages needed for this tutorial are Aladin, T OPCAT and STILTS.
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Aladin

Launch Aladin: Open a terminal and type: java -jar Aladin.jar &
Discovery: Search 2MASS-PSC and SDSS-DR9 sources around RA: 08h30m, DEC: 01d30m with a
14 arcmin radius.
• Enter the coordinates 08:30 01:30 in the Command line of Aladin
and press Enter.
• In the main viewing window the DSS colour image centred on the entered coordinates appears.
Zoom in and out by scrolling with your mouse or by using the zoom register on the right hand
side. Aim for a field of view of approximately 14 × 14 arcmin. Hint: the cyan/blue numbers
in the bottom of both the main viewing window and the overview window in the bottom right
corner of Aladin state the current field of view.
below the DATA T REE. This will filter
• Enter "2MASS PSC" in the select line
the entries in the DATA T REE to only show those that are affiliated with the 2MASS point source
catalogue. Note how some entries are coloured in green and some in orange. This indicates
whether a resource has data available in the current field of view (green) or not (orange).
• Choose the only green entry (Catalog → VizieR → II-Photometric Data → 2MASS-PSC...)
by clicking on it. In the pop-up window, make sure to tick in view

and Load the data

(see Figure 1). This will load a catalogue of approximately 1000 sources (Aladin will
give you the number of rows of a catalogue when hoovering over the entry of the catalogue in
the stack on the right of the main viewing window). You can change the appearance and name
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of the data by selecting the plane "CDS/II/246/out" in the stack and clicking the properties
button. Alternatively right-click on the plane and select Properties.... Rename the plane to
"2MASS-PSC".

Figure 1: Loading the data available in the current field of view from the 2MASS-PSC in Aladin.
• Now we repeat the same steps for the SDSS-DR9 catalogue:
– Enter "SDSS DR9" in the select line.
– Choose the first green entry: Catalog → VizieR → V-Combined Data → SDSS-DR9....
– Load the SDSS-DR9 catalogue data in view, which will include of the order of 15,000
sources. Rename the new plane to "SDSS-DR9".
Crossmatching: In this next step, we find common sources in the 2MASS-PSC and SDSS-DR9 catalogues.
• Open the Catalog Cross-match tool by either clicking the cross-match button
the menu Catalog → Cross match objects ....

or opening

• In the Catalog Cross-match tool enter the two catalogues and their coordinate columns, keep
the default threshold for source separation (0 ≤ threshold ≤ 4) and select Best matches (see
Figure 2). Make sure that the catalogue with the smaller number of sources is named in the first
line. Then hit Perform cross-match. A new plane called "XMatch" will appear in the stack. It
contains almost as many sources as the 2MASS-PSC plane.

Figure 2: Cross-matching 2MASS-PSC and SDSS DR9 in Aladin.
Filtering: Select those sources from our cross-match catalogue that are SDSS point sources and have
characteristics that are expected from brown dwarfs.
• Hide the 2MASS-PSC and SDSS-DR9 planes by clicking on
. Note that moving the green
controller button in the bottom of this symbol changes the opacity of the plane.
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• Select the XMatch plane by clicking on it. Open the Filter properties window by either using
the Filter button

or following the menu through Catalog → Create a filter....

• In the opened window Properties of the filter move to the Advanced mode tab. Click on the
button and chose Columns in loaded catalogs.... Select the "cl_tab2" column from
the XMatch catalogue.
• Complete the filter condition. It should be ${cl_tab2}=6 {draw}. This tells Aladin that
only sources from the XMatch table that adhere to the condition cl_tab2=6 should be shown
in the main viewing window. The Actions, Maths..., Units and UCDs buttons next to the
Columns... button further help in constructing filter.
. This will apply the filter to the XMatch plane. Clicking
will
• Click on
create a new plane "Filter.src", which only contains those sources from the XMatch plane that
comply with the filter criterion. Approximately 100 sources will be excluded by this filtering
action.
Now that we have limited our sample to point sources according to the SDSS data, we move on
to select brown dwarf candidates. Brown dwarfs are cool objects so they are not detected in the blue
SDSS bands. We therefore select sources with no detection in the u and g SDSS bands (u > 22.0
&& g >22.2. We furthermore search for sources fulfilling the brown dwarf criteria provided by
Burgasser et al. (2000, ApJ, 531, L57): ((J-H)<0.3 && (H-K)<0.3).
• Hide the XMatch plane.
• Select the "Filter.src" plane. if you wish you can again change name colour and plotting symbol
by using the

button.

• Repeat the same steps as for the previous filter. The filter condition should now be: ${umag_tab2}
> 22.0 && ${gmag_tab2} > 22.2 && ${Jmag_tab1} - ${Hmag_tab1} < 0.3
&& ${Hmag_tab1} - ${Kmag_tab1} < 0.3 {draw}
• Click on

. Then click on

to create a new plane with the filtered sources.

• A new plane "Filter.src∼1" will be loaded in the Aladin main window. It should contain
1 source. (RA_2MASS:127.703265 deg; DEC_2MASS:1.475320 deg). Note that the corresponding table column will be shown when double-clicking on the source.
• If you have the Simbad pointer enabled (see Figure 3), hoover with the mouse over the source
until a small grey window appears. This grey window already tells you the name (2MASS
J08304878+0128311) and the object type (brownD*) of the source. In order to visit the SIMBAD page for this source, click on the name.
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Figure 3: Enabling the Simbad pointer in Aladin and getting basic information on our resulting source.
Hurray, it is indeed a brown dwarf!
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T OPCAT

Launch T OPCAT: Open a terminal and type: java -jar topcat-full.jar &
Discovery: Search 2MASS-PSC and SDSS-DR9 sources around RA: 08h30m, DEC: 01d30m with a
14 arcmin radius.
• In the T OPCAT main window follow the menu to VO → VizieR Catalogue Service. A new
window (VizieR Catalogue Service) opens.
• In this new window select Cone Search
and units:
RA: 08:30:00
Dec: 01:30:00
Radius: 14

and enter the coordinates, radius

• In the bottom half of the VizieR Catalogue Service window, choose the Surveys tab, find and
select "2MASS-PSC" and then click OK. This will load the table "II_246_out" with 683 rows
(i. e. sources) in the T OPCAT main window.
• Repeat the previous steps for SDSS-DR9. This will load the table "V_139_SDSS9" with 12,404
sources into the T OPCAT main window.
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• Alternatively, you could broadcast the 2MASS and SDSS DR9 catalogs from Aladin to T OPCAT
using SAMP (Simple Application Messaging Protocol): In Aladin, right-click on the "2MASSPSC" plane in the stack. Then select Broadcast selected tables to ... → topcat (see Figure 4).
The table should appear in the T OPCAT main window. Use the same approach for the SDSS
DR9 sources.

Figure 4: Broadcasting a table from Aladin to T OPCAT via SAMP.
Crossmatching: In this next step, we find common sources in the 2MASS-PSC and SDSS-DR9 catalogues.
• Open the T OPCAT Match Tables window by either following the menu in the main window to
Joins → Pair Match or simply using the
button.
• In the Match Tables window set the following parameters (see Figure 5):
– In the Match criteria box:
Algorithm: Sky
Max error: 4 arcsec
– Table1: II_246_out (2MASS-PSC). RA/Dec columns: RAJ2000, DEJ2000.
– Table2: V_139_sdss9 (SDSS-DR9). RA/Dec columns: RA_ICRS, DE_ICRS.
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– Output Rows box:
Match selection: Best match, symmetric
Join Type: 1 and 2
Then click Go, get the notification that 679 pairs were found and confirm that a new plane
"match(1,2)" with 679 sources is loaded.

Figure 5: Cross-matching the 2MASS PSC and the SDSS DR9 tables in T OPCAT.
Filtering: Select those sources from our cross-match catalogue that are SDSS point sources and have
characteristics that are expected from brown dwarfs.
• Again, we first remove all sources that not SDSS point sources. To do so select the "match(1,2)"
table and then open the T OPCAT subset window by either following the menu in the main
window to Views → Rows Subsets or use the

button.

• In the newly opened window Row Subsets create a new subset by clicking

.

• In the new Define Row Subset window fill in the form with:
Subset Name: filt1
Expression: cl==6 or $24==6. The second option is particularly useful when two columns
have the same name except for upper and lower case e. g. one named "cl" and another one
"CL", because T OPCAT expression are case insensitive. You can find the number of a column
in the table metadata, accessible via

.

• Click OK. In the Current Table Properties panel in the main window, you can now select
in the Row Subset dropdown menu between All or filt1. If you chose filt1, 649 sources are
included in the table.
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• Before we move on, let’s have a look at the content of the new table. To do so click
will open a new window within which you can scroll through the table.

. This

• In order to implement the brown dwarf selection criteria, we have two options:
– Go back to the Row Subset window of the match(1,2) table (which table the window is
working on is mentioned in the line below the buttons). Add a second subset with (see
Figure 6):
Subset Name: filt2
Expression: cl==6 && umag>22.0 && gmag> 22.2 && Jmag-Hmag<0.3 &&
Hmag-Kmag<0.3
– Select the match(1,2) table and for Row Subset filt1. Then duplicate the table by following the menu to File → Duplicate Table. This will create a new table called "Copy of 3"
that only includes the rows of the filt1 subset. Now we can create a new subset of this table
by first selecting it in the main window, then opening the Row Subsets window with
and adding a new subset with
. The Expression would be umag>22.0 && gmag>
22.2 && Jmag-Hmag<0.3 && Hmag-Kmag<0.3.
The second option might appear a bit cumbersome but will come in handy for more complex
analyses. Either way, after the filtering process only one source remains: RA:127.703265 deg;
DEC:1.475320 deg.

Figure 6: Subset of the cross-matched 2MASS PSC/ SDSS DR9 tables in T OPCAT.
• In order to visualise the source and check whether it is indeed a brown dwarf, you could now
broadcast the filtered table to Aladin (if Aladin is running):
– In the T OPCAT main window select the match(1,2) table and filt2 as the row subset.
or go through the menu Interop → Send table

– Now either click the broadcast button
to... → Aladin.

– Now a new table should appear in the Aladin stack and you can proceed as before.
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Advanced Scripting in Aladin

Aladin has a script mode to build a list of commands to be processed. The workflow can be executed
automatically for a list of targets. If you closed Aladin launch it again (java -jar Aladin.jar
&). If Aladin is open, click on any plane, click right mouse button and select "Delete all planes" (to
clean up a little bit before we move on).
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• Before we get started in Aladin, we create two text files in any text editor and save them. The
content of the script file looks as follows:
2mass = get VizieR(2MASS-PSC) $1 $2 14'
sync
sdss = get VizieR(SDSS-DR9) $1 $2 14'
sync
2massdss= xmatch 2mass sdss 4 bestmatch
sync
hide 2mass
sync
hide sdss
sync
filter candidates { ${cl_tab2}==6 && ${umag_tab2}>22.0 &&
${gmag_tab2}>22.2 && ${Jmag_tab1}-${Hmag_tab1}<0.3 &&
${Hmag_tab1}-${Kmag_tab1}<0.3 {draw} }
#(the 3 lines above are 1 single line, remove the tabs and linebreaks)
sync
select 2massdss
sync
cplane candidates
The parameter file looks like this:
# RA DEC
08:30:00, 01:30:00
• Now go back to the Aladin main window and open an Macros window by using the menu Tool
→ Macro controller....
• In the Macros window use the menu to load the script file: go to File → Load script or type
CTRL+S. Select and open your script file from where you saved it before.
• Now do the same for the parameter file: go to File → Load params or type CTRL+P. Select
and open your parameter file from where you saved it before.
• Select the coordinate by clicking on their entry in the Macros window and push Exec. current
. Aladin will now go through the script executing the steps we took
params
before by itself. Once Aladin is finished you should see one source highlighted on the screen,
which is again the brown dwarf we identified before.
More information on how to build scripts in Aladin can be found in the Aladin menu at: Help →
Help on script commands or by using CTRL+F5.
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STILTS

STILTS has the same underlying library as T OPCAT but is a command-line tool and can thus be
scripted.
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• Copy the file "stilts.script" (http://cds.unistra.fr/tutorials/CDS-tutorial/
stilts.script) to your local computer. You may also use the version further below. For
the version below, be aware that line-breaks had to be inserted to be able to fit the commands
on an A4 page. Make sure that you remove all line-breaks, for which the old line does not end
with a "\" and the new line has an extra large indent (i. e. all line-breaks that are within a string,
an URL, ...). Leave no blank spaces, where you remove these line-breaks.
• Make the script executable by typing chmod u+x stilts.script into a command line.
• Execute it by entering ./stilts.script into a command line. A new file ("candidate.xml")
is created. It contains the same single object found in the previous workflows.
The commands included in the STILTS script to find the brown dwarf:
java -jar /path/to/stilts/stilts.jar tpipe \
'in=http://vizier.u-strasbg.fr/viz-bin/conesearch/II/246?
-out.max=unlimited&verb=3&RA=127.5&DEC=+1.5&SR=0.2333333 ' \
out=2mass.xml
java -jar /path/to/stilts/stilts.jar tpipe \
'in=http://vizier.u-strasbg.fr/viz-bin/conesearch/V/139?
-out.max=unlimited&verb=3&RA=127.5&DEC=+1.5&SR=0.2333333 ' \
out=sdssdr9.xml
java -jar /path/to/stilts/stilts.jar tskymatch2 ifmt1=votable in1=2mass.xml \
ifmt2=votable in2=sdssdr9.xml ra1=RAJ2000 dec1=DEJ2000 ra2=RA_ICRS \
dec2=DE_ICRS error=4 find=best join=1and2 ofmt=votable out=cross.xml
java -jar /path/to/stilts/stilts.jar tpipe ifmt=votable in=cross.xml \
cmd='select "cl==6 && umag>22.0 && gmag>22.2 &&
Jmag-Hmag<0.3 && Hmag-Kmag<0.3" ' \
ofmt=votable out=candidate.xml
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