ASTERICS - H2020 - 653477
An introduction to the
CDS services and tools
Ada Nebot Gomez-Moran, Mark Allen and the CDS team
Centre de Données astronomiques de Strasbourg, France

Jenny G. Sorce
updated with a new template for ASTERICS with the new CDS portal, new plots

last update 11.14.2017

1

Contents
1

Introduction

3

2

Goal of this tutorial

3

3

Search for information on NGC4039 in the CDS Portal
3.1 SIMBAD - Identifiers, Basic Measurements and links to the Bibliography . . . . . .
3.2 Aladin - Images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
3.3 VizieR - Catalogs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

3
4
5
6

4

Search for data on NGC4039 in Aladin

7

5

Compare the coverage of Sky Surveys and select interacting galaxies that have SDSS and
GALEX data

9

6

Collect information on a sample of galaxies using Aladin [Optional]

2

12

1

Introduction

The CDS harbors three major programs, accessible through the CDS portal:

•

SIMBAD: The astronomical database SIMBAD contains more than 8 million objects. For each object it provides basic measurements (type, coordinates, proper motion, radial
velocity, spectral type, distance, magnitude), cross-correlations and bibliography.

•

The VizieR catalog service provides access to about 15,000 catalogs, being the
most complete library of published astronomical data tables available online.

•

Aladin: The interactive sky atlas Aladin allows to visualize astronomical images and
to superimpose entries from different catalogs and databases. It allows to visualize SIMBAD
and VizieR information and distributed archives and databases as well as to upload own tables
or images. There are two versions of Aladin: Aladin desktop and Aladin lite which runs in the
browser.

V izie R :

Besides these tools, the CDS has been providing a cross-match service (X-match) since November
2011.
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Goal of this tutorial

This tutorial shows how to use the CDS tools to gather information on specific astronomical objects.
We will:
• Search for information on NGC4039 in the CDS portal
• Search for data on NGC4039 in Aladin
• Compare the coverage of Sky Surveys and select interacting galaxies that have SDSS and
GALEX data
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Search for information on NGC4039 in the CDS Portal

Open the CDS Portal http://cdsportal.u-strasbg.fr/ and make a query for ‘NGC4039’. The result
provides an overview of the information and data available for this object in the 3 CDS services:
SIMBAD, Aladin and VizieR:

Figure 1: Query for NGC4039 in the CDS Portal
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3.1

SIMBAD - Identifiers, Basic Measurements and links to the Bibliography

Figure 2: Result of the query for NGC4039 in the CDS Portal
• Click on More info in Simbad to see the full SIMBAD information on this object in a new
tab.

Figure 3: Result of the query for NGC4039 in SIMBAD.
• Note the list of Other object types. These types are drawn for the literature and are stored
in SIMBAD using a hierarchical classification scheme. The full list of Object Types can be
found here: http://simbad.u-strasbg.fr/simbad/sim-display?data=otypes. The main Object Type
of NGC4039 is Galaxy in Pairs of Galaxies (GiP).
• Use the siblings button

to identify the name of the other galaxy in this interacting pair.

can help bring out the most important ones. What is
Sorting by the number of references
the separation in arcseconds of these two galaxies?
• Use the References section to find the earliest listed reference in the literature to this object.
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Figure 4: References section
• Return to the CDS portal.

3.2

Aladin - Images

Figure 5: Result of the query for NGC4039 in the CDS Portal
• A DSS (Digitized Sky Survey) image of NGC4039 is shown.
• Note that you can zoom on the image by scrolling your mouse.
• Other images can be displayed by selecting them in the left column.
• Restricted searches on wavelength and resolution are possible by ticking/unticking the boxes in
that same column.
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3.3

V izie R

- Catalogs

Figure 6: Result of the query for NGC4039 in the CDS Portal
• The list of catalogs is sorted by Popularity but can also be sorted by number of rows (#rows),
sky fraction or year.
• Note that restrictions and filtering can be applied by clicking on the left or right columns according to your wills.
• Selecting a catalog, it is then possible to visualize it (either quickly or in VizieR), to plot it
and/or to send it to the Aladin tool.

Figure 7: Selection of a VizieR Catalog on the CDS Portal.
• Actually the Antennae is listed in the Arp Atlas of Peculiar Galaxies, make a search for ‘Arp’
into the Search box.

Figure 8: Looking for ‘Arp’ in the VizieR catalogs.
• Note that there are two tables for Webb 1996. Select the arplist table by clicking on it and then
on

. This sends to the VizieR detailed query page.

6

• Make a first query on this table by clicking on submit. Examine the output as html. Go back to
the previous page
• Modify the query preferences to add extra coordinate columns in J2000 decimal degrees and to
obtain the whole catalog:
- Remove the restriction on searching only around ‘NGC4039’ by clicking on the Clear button
below Target Name (resolved by Sesame) or Position at the top of the page.
- In Preferences on the left side of the page, add extra coordinate columns in decimal degrees
by ticking J2000 and decimal boxes.
- Change the maximum (max) number of rows to unlimited and tick All columns to get the
whole catalog.

Figure 9: Preferences panel.
- Submit again.
• When satisfied, click on Save in CDSportal, then click on the Save button. The file is now
saved in your personal user space on the CDS portal.
• Click on Go to MyData and download a copy in VOTable format on your desktop. This file
will be used later in the tutorial.

Figure 10: Personal User Space on the CDS Portal.
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Search for data on NGC4039 in Aladin

Open Aladin with at least 1GB memory allocated to the save virtual machine. To do so use the
following command line: ‘ java -Xmx1024m -jar Aladin.jar ’
Open the S ERVER SELECTOR window via File → Open or by clicking the File icon
at the top
left corner of the Aladin window or CTRL+i. The S ERVER SELECTOR provides access to Images
7

servers on the left, Catalog servers on the right and to a range of services including all VO at the
top.

Figure 11: S ERVER
NGC4039

SELECTOR

of the Aladin tool, Aladin images has been selected for a query on

• Insert in the Target box, ‘NGC4039’ in the Aladin images tab of the Image server and click
on submit.
• Select a 13’x13’ DSS image from the list and load it (tick the box and submit again). Note that
it loads as a plane into the stack on the right panel of the Aladin window.
• Make a contour map of the image using the cont button
number of contours to better represent the image.

next to the stack. Increase the

• Overlay a SIMBAD plane showing only the galaxies by selecting the
tab of the Catalog
servers in the S ERVER SELECTOR and choosing Galaxy as the Display filter.
• Change the color of the SIMBAD plane using the button Properties
• Using the select tool

, select some of the SIMBAD points and note that these are displayed

as a table below the image. Note that this window can be detached with the icon

.

• Select 2MASS J, H and K bands images from the Aladin images tab in the S ERVER
TOR

window and construct a color image with the rgb tool

SELEC -

.

• Select an image from the Hubble Press Release images:
- File → Load Astronomical Image → Others → Hubble Press Release Images
- or via the Others in the Image servers in the S ERVER SELECTOR window.
• Compare the images in a number of different ways:
- Multiview: View → Create one view per image, or via the multiview icon at the bottom left
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of the Aladin image window

.

- Align and scale all images by using the match icon below the image window
- Transparency overlays: return to single view mode. Change the transparency of planes in the
. Note that you can move the location of
stack with the opacity sliders below each plane
the planes in the stack.
• Search the VO for data on NGC4039:
- Use the All VO tab
in the S ERVER SELECTOR to search for more images, catalogs and
spectra.
- Make a general query for data from all the VO services accessible via Aladin by clicking on
Submit. When a number of results have returned, click on Stop.
- Expand some of the nodes of the tree. Note how the Field of View from some services is
displayed over the images in the Aladin image window.

Figure 12: Results of all the above mentioned steps.
- To make a restricted search use the Detailed List. To do so, first unselect all, then choose
the services you want to query (note that the Filter text box can be used to search the list), e.g.:
‘Hubble Legacy Archive’, ‘Skyview Virtual Observatory’, ‘Chandra X-Ray Observatory Data
Archive’.
- Submit (bottom of the S ERVER LIST) to load selected images.
- Display the images in multiview mode and note that you can align all the images to the same
orientation and scale using the match icon.
• Now delete all the planes in your stack before continuing. This is not mandatory but it will free
some useful memory space and allow you to proceed more easily with the next steps.
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Compare the coverage of Sky Surveys and select interacting
galaxies that have SDSS and GALEX data
• Browse the available surveys by clicking the HiPS (Hierarchical Progressive Survey, see http://aladin.ustrasbg.fr/hips/ for more information) tab in the S ERVER SELECTOR window.
• Select the SDSS 9 colored (Image → Optical → SDSS) and GALEX All Sky Imaging Survey
colored (Image → UV → GALEX) surveys and submit.
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Figure 13: Selecting the SDSS 9 colored survey
• Turn on the coordinate grid

, zoom out and use the pan tool

to explore the whole sky.

• Go into multiview mode and match the views so that they can be panned and zoomed together.
• Load the coverage map (MOC - Multi-Order Coverage map) of both the SDSS and GALEX
surveys from the properties panel for each plane and click on Coverage. Zoom onto the edges
of the surveys and note the way the MOC represents the coverage of the surveys.

Figure 14: Displaying the coverage map
• Calculate the intersection of the coverage maps of the SDSS and GALEX surveys using in the
menu the item Coverage → Logical operations.
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Figure 15: Building the intersection of the coverage maps
• Load the full Webb 1996 Arp catalog that you saved earlier. You can do this in one of the two
ways:
- file → load
- drag and drop on the images
Alternatively you can download again the catalog via the VizieR interface in the Catalogue
Servers in Aladin.
• Filter the catalog to select only the sources that fall within the SDSS+GALEX MOC: Coverage
→ Filter a table by MOC: 425 sources are selected.

Figure 16: Filtering a catalog by a MOC
• Visualize the brightest (<9 mag) galaxies of the selected sources by extracting small images
from the SDSS survey:
- Select the brightest galaxies using the filter tool grid
: select the Show brightest stars
predefined filter and edit it with the Advanced mode to select object with magnitude below 9. Note that the column is automatically identified with the Unified Content Descriptor
‘ phot.mag* ’.
- Make sure that only MOC filtered catalog is active in the stack (or other sources may also be
filtered). An easy way to ensure that is to delete every catalog not useful anymore.
- Click on Apply and then Export to create a new plane consisting only of sources selected by
the filter. There are 7 sources with magnitudes below 9.
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Figure 17: Filtering a catalog by magnitude
• Make thumbnails of the selected brightest sources: Tools → Thumbnail view generator

Figure 18: Thumbnails
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Collect information on a sample of galaxies using Aladin [Optional]

Use an Aladin script to obtain DSS and SDSS image with HST, Chandra, ESO observation log overlays for each of the selected bright galaxies.
• Copy the script Arp script.ajs from the url http://cds.unistra.fr/tutorials/CDS-tutorial/Arp
http://cds.unistra.fr/tutorials/CDS-tutorial/Arp_script.ajs
script.ajs
to your computer. The content of the script is shown in Figure 19
• Create a folder called ‘Arp’ and edit the script Arp script.ajs to insert a path in order to save the
output files, e.g. ∼/Desktop/Arp.
• Open the Aladin macro controller and load the script:
- Tools → Macro Controller then File → Load script
- or cut and paste the script into the top panel of the M ACROS window.
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• Select all the sources in the bright galaxy catalog:
- Right click on the plane and Select all objects in the selected planes
- In the M ACROS window: File → Use selected plane sources as params.
- Note how the catalog columns are shown as parameters which can be referred to as $1, $2, etc
within the script.
• Click on the first row of the parameters table and execute the script for this row: Exec current
params.
• Optional: add an SDSS image: remove the ‘#’ to enable download of a SDSS g-band image
for each source. Note that this results in an Could not find any data corresponding to your
request message for objects not covered by SDSS.
• Inspect the output in the Aladin window and also the files written in the Arp folder.
• Execute the script for all sources: Exec all from current.
• Note that the saved stack files can simply be dragged and dropped into Aladin for inspection.

Figure 19: M ACROS window & Arp script.ajs

13

